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Flash was originally a program for ■■

creating animation with interactivity, but 
it has evolved; now it is also a tool for 
building media-rich Web applications.
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Basic Concepts
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Objects are organized in a Flash ■■

document, then the result is exported as 
a Flash movie to be embedded in a Web 
page or played on a mobile device.
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A Flash movie (or SWF) is composed of ■■

one or more frames. Movies can also be 
exported as a sequence of still images or 
as video.
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Documents can be created from scratch ■■

or from a template.
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The timeline shows the sequence of ■■

frames over time, from left to right.

The stage is a window in which individual ■■

frames can be created and edited.
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Flash documents are composed of layers, ■■

which are displayed in the timeline.
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Artwork
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Flash is fundamentally a vector graphics ■■

application.
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Draw lines with the pencil, line or pen ■■

tools.
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Set the colour, weight and style of strokes ■■

in the Properties panel; set extra options 
for the pencil at the bottom of the Tools 
panel.
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Set the colour of fills and strokes in the ■■

Properties panel, Tools panel or Color 
panel.
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In Flash, Alpha means transparency. Fills ■■

and strokes can be semi-transparent.



146Digital media t ool s fl ash

Pick up strokes and fills from existing ■■

shapes with the eyedropper and transfer 
them to other objects with the ink bottle 
or paint bucket, respectively.



156Digital media t ool s fl ash

Use the rectangle, oval and polystar tools ■■

for drawing geometrical shapes.
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Use the brush tool for more natural ■■

looking marks. Brush marks are actually 
filled shapes, with invisible strokes. 
Turn on options in the Tools panel for 
sensitivity to pressure and tilt if you use a 
graphics tablet and pen.
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In merge drawing mode – the default ■■

– shapes and lines are split where 
they overlap and stroke and fill can be 
selected separately.
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In object drawing mode, objects don’t ■■

interact when they overlap and can 
be selected as a whole. Use the round 
button near the bottom of the Tools panel 
to turn object drawing mode on and off.
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Use the black arrow tool to select objects ■■

or lines. Use the lasso tool to draw a 
freehand selection; turn on polygon 
mode to use the lasso like the line tool.
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Use the free transform tool or the ■■

commands on the Modify>Transform 
command to move, scale, rotate or skew 
objects.
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Objects can be aligned or uniformly ■■

distributed vertically and horizontally 
using the Align panel.
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A symbol is an element that can be ■■

stored in the library and used repeatedly. 
You can turn existing artwork into 
a symbol using Modify>Convert to 
Symbol… or create a new symbol before 
you have done the drawing.
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To create an instance of a symbol, drag ■■

it from the Library panel onto the stage.
Editing a symbol alters all the instances 
of it.
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Instances can be individually transformed ■■

or have colour effects applied. Editing an 
instance does not affect other instances 
of the same symbol.
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Artwork created in other programs, ■■

including Illustrator and Photoshop, can 
be imported to the stage or the library.
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Animation
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For animation, a frame rate of 12 frames ■■

per second is usually sufficient to create 
an illusion of smooth motion. Frame rate 
can be changed in the Properties panel, 
but slower rates will generally result in 
jerky movement.
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Animate one frame at a time by adding ■■

keyframes to the timeline and creating 
their content on the stage.
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Insert>Timeline>Keyframe adds a ■■

keyframe whose contents are a copy of 
the previous frame, which you can then 
modify.

Insert>Timeline>Blank Keyframe adds a ■■

blank keyframe.
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Turn on onion-skinning to see adjacent ■■

frames overlaid on one another.
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Use Control>Play to watch your ■■

animation on the stage, or Control>Test 
Movie [ctl enter/cmd return] to play it in a 
Flash Player.
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Use File>Import>Import to Stage to ■■

import numbered image sequences if you 
have created the content of your frames 
in another program. Discontinuity in the 
numbering of the image files will mean 
only some are imported.
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Animated GIFs can be imported; each ■■

frame will be automatically converted to 
a keyframe.
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Layered Photoshop or Illustrator files ■■

can be imported; selected layers will be 
converted to keyframes if you choose the 
correct option in the dialogue.
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Use motion tweening to automatically ■■

interpolate the position, size, rotation, 
brightness, colour and transparency of an 
instance of a symbol.
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Each instance to be motion tweened ■■

must be placed on a separate layer. 
Successive motion tweens of the same 
instance may be created on the same 
layer.
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To create a motion tween, drag a symbol ■■

to a keyframe at the start of the tween, 
create another keyframe at the end 
and move the instance or change its 
properties. Then select a frame in between 
the start and end and set the Tween 
pop-up to Motion in the Properties panel.
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Unlike keyframes, tweened frames ■■

have no content; they are generated 
automatically when the movie is played 
back.
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Use custom easing to vary the rate ■■

of change during the tween. Different 
tweened properties can be eased 
independently.
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Use a motion guide on a guide layer to ■■

make an object move along a path that 
isn’t a straight line. Any path may be 
drawn with the usual tools, or imported 
from Illustrator.
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To detach a layer from a guide layer, use ■■

the Modify>Timeline>Layer Properties… 
command and select the Normal radio 
button under Type, instead of Guided.
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Select frames and keyframes by clicking ■■

on them in the timeline.

Drag the red bar through the timeline to ■■

set a new current frame; this does not 
automatically select the frame, however.
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Use the commands on the Edit>Timeline ■■

sub-menu to cut, copy, paste and delete 
frames. Using the delete key or Edit>Cut, 
etc. will delete frames’ contents, but not 
the frames themselves.
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Copy and paste motion tweening and ■■

easing curves to make several objects’ 
tweened properties change over time in 
the same way.
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Use timeline effects to create transitions, ■■

such as dissolves. Preview effects in the 
Flash Player if they do not show up when 
playing through the timeline.
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Create movie clip symbols and graphic ■■

symbols with more than one frame as 
reusable animations within a movie.
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You can set the colour (tint), alpha, size, ■■

etc. of instances of animated symbols 
independently, in the same way as for 
still graphic symbols.
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Movie clip symbols have their own ■■

independent timelines and can be 
controlled by scripts; instances of movie 
clip symbols can be added to a single 
keyframe in the main timeline.
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For animated graphic symbol instances ■■

you need to create sufficient frames in 
the main timeline for the duration of the 
animation.
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Apply filters to movie clip instances, ■■

button instances or text objects to 
produce graphic effects such as glows 
and drop shadows. Tween the filter 
settings using motion tweening, to 
produce easy motion graphics.
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Use shape tweening to morph one shape ■■

into another. Shape tweening cannot 
be applied to symbols, but otherwise 
is applied in almost the same way as 
motion tweening. Test the results – they 
can be unpredictable.
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Shape tweening is computationally ■■

intensive; use it with discretion.
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Use shape hints for more control over ■■

morphing.
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Sound and Video
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Import sound files in common formats ■■

into the Library.
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Create new layers for sounds. Add a ■■

sound at a keyframe by selecting it from 
the Sound pop-up in the Properties panel.
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Event sounds start to play when the ■■

keyframe is reached and continue to play 
until they reach their end. Use them for 
spot effects.
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Stream sounds are synchronized to the ■■

movie. Use them for soundtracks. The 
picture may play jerkily when movies 
with synchronized sound are played over 
slow connections. Sound files can be 
large.
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Use the Sync pop-up to choose between ■■

event and stream sounds.
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Flash Video (FLV) files can be exported ■■

from popular video editing programs, or 
created by importing video in some other 
format into Flash.
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Streamed video uses the Flash Media ■■

Server to deliver frames which are played 
as soon as they arrive on the user’s 
machine.
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Progressively downloaded video is ■■

downloaded to the user’s machine and 
starts playing as early in the download as 
possible.
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Embedded video becomes part of the ■■

SWF file; it should only be used for very 
short clips.
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Use the Video Import Wizard to import ■■

video, select streaming, progressive 
download or embedding, and set 
parameters for encoding as FLV.
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Flash Video is highly compressed, with ■■

consequent loss of picture quality.



6Digital media t ool s

End of the “Don’t Forget” key point slides ■■

for Chapter 6, pages 287–355 of  
Digital Media Tools, 3rd edition 

published by John Wiley & Sons, 2007

 ■■

© 2007 Nigel Chapman and Jenny Chapman


